Domain Incident
Incident Report for Vozy
Resolved
Domain Incident Solved
Posted over 1 year ago. Feb 27, 2018 - 09:10 UTC
Investigating
This issue was reported to cloudflare services. We hope to have the service back soon.
Posted over 1 year ago. Feb 27, 2018 - 07:59 UTC